Como fazer uma fórmula com a função SE do Excel?


SE Excel Função e Fórmula
SE Excel Função e Fórmula

Allisson da Silva
CEO da Compra Ae. Fundador da Osruc.

O que é a função SE?

A função SE é uma função do Excel que realiza um ou mais testes lógicos dentro de uma fórmula, e gera dois resultados no editor de planilhas da Microsoft: um veredeiro e outro falso .

Uma fórmula contendo SE pode ser montada realizando testes com os operadores matemáticos como o <, >, <>, <=,>= e o =, assim como funções lógicas com NÃO, E e OU.

Um SE pode ser aninhado e operar com outras funções SE aumentando assim a quantidade de testes em fórmulas que vão de básicas a mais complexas.

Este artigo irá lhe mostrar em cerca de 5 minutos como construir uma fórmula com a função, assim como apresentará exemplos que possam esclarecer com mais propriedade o uso do recurso em sua planilha.

Objetivo

Realizar testes lógicos e gerar dois resultados, sendo um verdadeiro e outro falso.

Como fazer uma fórmula com SE?

=SE(Teste lógico; Resultado verdadeiro; Resultado falso)

Argumentos

  • Teste lógico - É o onde um dado será testado

  • Resultado verdadeiro - Será executado caso o teste tenha gerado um valor verdadeiro

  • Resultado falso - Será executado caso o teste tenha gerado um valor falso

Valor de retorno

Retornará o resultado do campo do resultado verdadeiro ou falso.

Como usar a função SE do Excel?

Para entender o uso da função SE, vamos considerar as etapas abaixo: 

1. Insira dados em um intervalo da planilha

Como fazer uma Fórmula com a Função SE do Excel - Step1
Como fazer uma Fórmula com a Função SE do Excel - Step1

Em primeiro lugar você deverá construir um intervalo com dados para podermos testar a fórmula com o SE. No seu Excel digite o exemplo da tabela abaixo. Caso queira, considere o intervalo apresentado pela na próxima tabela. Copie e cole a tabela no seu Excel começando da célula B5:

DIA TIPO
SEG =SE(B6="SAB";"FIM DE SEMANA";"DIA ÚTIL")
TER
QUA
QUI
SEX
SAB
DOM


2. Inicie a fórmula identificando um intervalo

Como fazer uma Fórmula com a Função SE do Excel - Step2
Como fazer uma Fórmula com a Função SE do Excel - Step2

Após inserir os dados em um intervalo você deverá começar a inserir a fórmula com o teste usando a função SE. Na linha C6 você digite um = para abrir as fórmulas do Excel. A fórmula SE a ser digitada é a seguinte:

=SE(B6="SAB";"FIM DE SEMANA";"DIA ÚTIL")

Caso já tenha copiado o exemplo do passo anterior, não será preciso digitar novamente a fórmula. Arraste apenas a formula clicando no quadradinho preto no canto inferior direito da célula C6 até chegar na célula C11, onde está o sábado.

Nessa etapa você está testando se o valor da coluna B é igual a palavra SAB. SAB é um texto e por isso sempre precisa estar entre aspas duplas.

Observe que "FIM DE SEMANA" e "DIA ÚTIL" também estão dentro de aspas duplas, pois eles também são textos.

3. Adicione funções lógicas opcionalmente

Como fazer uma Fórmula com a Função SE do Excel - Step3
Como fazer uma Fórmula com a Função SE do Excel - Step3

Veja que na etapa anterior você inseriu fórmulas até a linha do Sábado. Isso foi proposital pois com aquela fórmula não poderíamos arrastá-la para linha C12, a do Domingo, pois na fórmula, SE só estava testando SAB para dizer se o dia era útil ou não. Sábado e domingo são dias não úteis. Então vamos melhorar nossa fórmula usando uma função lógica OU. Corrija sua fórmula na linha C6 para a seguinte fórmula:

=SE(OU(B6="SAB";B6="DOM");"FIM DE SEMANA";"DIA ÚTIL")

OU é uma função lógica do Excel que realiza testes e gera  um valor VERDADEIRO se qualquer um dos seus testes derem VERDADEIRO.

Observe a fórmula e vamos fazer a leitura da mesma:

Se o valor de B6 for igual a SAB ou o valore de B6 for igual a DOM imprima FIM DE SEMANA, caso contrário imprima DIA ÚLTIL.

Veja que ou OU poderá ter vários testes, mas no exemplo acima só precisava de dois testes: um para sábado e um para domingo


Notas sobre a fórmula feita com a função

Segue uma tabela com os operadores de comparações:

OPERADOR SIGNIFICADO EXEMPLO
= igual a A1 = B1
> maior que A1 > B1
>= maior que ou igual a A1 >= B1
< menor que A1
<= menor que ou igual a A1 <= B1
<> diferenteA1 <> B11

Mais outras observações:

  • Caso algum dos argumentos da função SE for fornecido como arrays, a função SE avaliará cada elemento do array.
  • Caso o campo de verdade não tenha sido preenchido e a fórmula, se verdadeira, retornará 0.
  • Caso o campo de falso não tenha sido preenchido e a fórmula, se falsa, retornará FALSO.

Versões compatíveis do Excel para o SE

Excel do Microsoft 365, Excel do Microsoft 365 para Mac, Excel para a Web Excel 2021, Excel 2021 para Mac, Excel 2019, Excel 2019 para Mac, Excel 2016, Excel 2016 para Mac, Excel 2013, Excel 2010, Excel 2007, Excel para Mac 2011, Excel Starter 2010


Baixe o arquivo da planilha Excel grátis




O que você achou?

Compartilhe:





Nenhum comentário publicado ainda.
Faça login para poder comentar




FaceFace