Função SEERRO Excel: O que é, como usar e como fazer fórmulas com SEERRO


Fórmula: Função SEERRO do Excel
Fórmula: Função SEERRO do Excel

Allisson da Silva
CEO da Compra Ae. Fundador da Osruc.

O que é a função SEERRO?

O SERRO é uma função do Excel para uso em fórmulas que pertence a categoria das funções lógicas do editor de planilhas da Microsoft.

A função SEERRO é um recurso do Excel para verificar erros no processamento de fórmulas. Toda vez que é usada, ela verifica se o processamento de suas fórmulas filhas do primeiro argumento, geram algum tipo de erro, sendo que, caso encontre algum, retorna o processamento do seu segundo argumento.

Ela é uma função muito importante, pois trata e garante o fluxo do processamento de dados da planilha, em operações que dependam do resultado de diferentes células. 

Este artigo irá lhe mostrar em 10 minutos como construir uma fórmula com a função, assim como apresentará exemplos que possam esclarecer com mais propriedade o uso do recurso em sua planilha.

Aprenda mais com nosso Curso de Excel

Objetivo

Tratar um erro encontrado na fórmula.

Como fazer uma fórmula com NÃO?

=SEERRO(Argumento de teste; Argumento de erro)

Argumentos

A fórmula possui dois argumentos:

  1. Argumento de teste: É a fórmula que o função vai analisar
  2. Argumento de erro: É executado caso um erro seja detectado no primeiro argumento da função SEERRO

Valor de retorno

O valor do processamento da formula no primeiro ou segundo argumento.

Como usar a função SEERRO do Excel?

Primeiramente para usar o SEERRO na fórmula é preciso verificar se o que se quer processar no Excel, pode ou não gerar algum tipo de erro.

Identificando a parte da fórmula que possivelmente gere um erro é hora de envolve-la com a função. Para isso analise a seguinte situação:

Você precisa calcular quanto pagará de comissão para seus vendedores. 1% do faturamento do dia vendido pelo site e na loja física é destinado para todos os vendedores que venderam no dia. 

Observe que temos então um possível erro no calculo da comissão do dia. No dia em que nenhum vendedor vender, e as vendas apenas acontecerem pelo site, ninguém receberá comissão.

Vamos então escrever uma fórmula para calcular isso, sem erro.

Crie um intervalo com dados

Crie um intervalo
Crie um intervalo

O primeiro passo será criar um intervalo com dados para que a fórmula possa obter informações para processar. Conforme o exemplo crie as seguintes tabelas na sua planilha:

Na célula B5 cole a tabela abaixo:

MEIO VENDAS
VENDA SITE 10.000,00
VENDA LOJA
TOTAL =SOMA(C6:C7)

Na célula E5 cole a tabela abaixo:

VENDEDORES COMISSÃO
0

Envolva a fórmula que se quer testar com o SERRO

Crie as fórmulas
Crie as fórmulas

Agora que você preencheu o intervalo, é hora de adicionar a fórmula principal envolvida com o SEERRO.

Na célula F6, na segunda tabela, logo abaixo do nome COMISSÃO, digite a seguinte fórmula:

=SEERRO(($C$8*1/100)/$E$6;0)

Adicione uma fórmula no parâmetro de erro

Fórmula no segundo parâmetro
Fórmula no segundo parâmetro

Veja que se você completou o passa anterior pôde perceber que existe um 0 (zero) após o ; na função.

Embora 0 não seja fórmula, também é possível inserir valores constantes no segundo parâmetro, e na resolução do problema posposto nesse material, o zero será a melhor resposta, pois se não existem vendedores vendendo, logicamente que não existirá comissão.

O SEERRO existe nessa fórmula para resolver o problema da divisão por zero, erro no Excel representado por #DIV/0!.

Exemplos de fórmulas

=SEERRO(5/0;"NÃO PODE DIVIDIR")

A fórmula acima retornará NÃO PODE DIVIDIR, pois uma divisão de 5 por 0 retornará um erro #DIV/0!.

=SEERRO(SE(A1>2;"A1 É MAIOR";"A1 É MENOR IGUAL");"EXCLUÍDO")

Caso a coluna A seja por algum motivo removida, a fórmula do SE receberá um erro do tipo #REF!. Como todo o conjunto da função está sendo tratado por um SEERRO, o resultado final será a exibição da mensagem EXCLUÍDO.

=SEERRO(A1+A2;"NÃO FOI POSSÍVEL SOMAR")

No exemplo acima se A1 contém um texto e A2 um número 7. O processamento dessa fórmula retornará um erro do tipo #VALUE!, pois não se pode somar textos com números em operações matemáticas. Para evitar esse tipo de erro poderia também ter usado a seguinte fórmula.

=SOMA(A1;A2)

Veja que no exemplo acima não foi necessário para a situação acrescentar o SEERRO. A própria função SOMA já faz essa correção.

Notas sobre a fórmula feita com a função

  1. Caso algum dos dois parâmetros da função sejam vazios, o SEERRO o tratará como ""
  2. Caso SEERRO trate um matriz, o resultado do processamento de erros também retornará uma matriz
  3. A fórmula com SEERRO tratará os seguintes erros do Excel: #N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME?, ou #NULL!

Versões compatíveis do Excel para o SERRO

Excel do Microsoft 365, Excel do Microsoft 365 para Mac, Excel para a Web, Excel 2021, Excel 2021 para Mac, Excel 2019, Excel 2019 para Mac, Excel 2016, Excel 2016 para Mac, Excel 2013, Excel Web App, Excel 2010, Excel 2007, Excel para Mac 2011, Excel Starter 2010


Baixe o arquivo da planilha Excel grátis




O que você achou?

Compartilhe:





Nenhum comentário publicado ainda.
Faça login para poder comentar




FaceFace